Tuesday, December 27, 2011

After replacing glow plugs Truck will not start?

This problem is faced on many dodge and ford diesel truck users.
After replacing glow plugs the truck will not start.Some times even smoke is noticed out of tail pipe while starting.
In this cases there are few possibilities that are to be checked inspected.
The fuel injectors-- If you have unplugged fuel injectors and not connected,fitted injectors properly then this problem can occur.Also check the fuses,wiring connections and fuel filter.

For understanding more,read this detailed explanation.
When you changed the glow plugs you also removed the valve covers. The valve cover harness is part of the gasket. A quick way to see if there is any issues with that is to run a check for codes. Theres a good chance the cylinders are loaded up with oil when changing the plugs, hence the smoke. you can try spraying some silicone into the intake and see if you can get it loping to fire. There is alot of concerns with the electircal connections in the valve cover gaskets, they fall apart and/or melt.Check all exterior connections and run codes see if any concerns are present to rule out injector issues.
Hard startig cold can be a glow plug issue, it can also be a timer issue with its control relay.Make sure it isnt overheated or melted.Check for codes and recheck the wiring inside the valve vcover and to the outside main connector for that bank. It should try to fire even if one bank is down.Also make sure the engine oil level is full and the correct oil.If it is too high ta fuel injector could be leaking down and fill the crankcase. Also too low could cause hard starting since it is a high pressure oil system.

Getting this possibilities checked will help.
Thanks.
---------
See list of more solved car problems :------

Car takes time to Crank and start?

http://howtobyme.blogspot.com/2011/12/car-takes-time-to-crank-and-start.html

Car jerks while going uphill and Check engine light is ON?


Car turns over, but only starts, if starter is jumped?


Service Engine Soon light stays on?


Gasoline around gas cap?


Car will not run after resetting inertia switch on Mercury Mystique?

VAN emits whitish bluish smoke and bad fuel smell from exhaust

Car cigarette lighter fuse blows out?



No comments:

Post a Comment