Tuesday, December 27, 2011

Intermittent rear air suspension losing air?

Ford Expedition:

2001 Ford Expedition looses air in the rear air bags after i cut it off. I don't hear any air leaks or anything.

The air bags release air after it sits. The rear raises back up after starting engine, if you add weight, it raises up even more to compensate for level suspension. It should be fine unless it's sitting almost on thr ground, but it does release air and sit lower.
There are fill and purge valves for each air bag, and a tiny bit of grit could have caused an intermittent leak that went away with subsequent airflow.

They are very expensive to find parts for if it fails totally later. Some folks have found parts on ebay. If it's not that important to you to have automatic leveling, you can buy coil springs to replace the airbags, and add airlift 1000 helper bags inside the coils if you need adjustability for towing or whatever.

The valves and computer are part of the pump assy. It doesn't talk on the normal serial data bus to a scan tool can't extract failure codes from it, but it WILL flash the LED near the tire inflator hose connector inside the car if it sees internal problems like leaks and sensor faults. We can interpret those codes.

The springs are a GM part. You will have to pay top $ to get them at a dealer, and they may have to get them from a warehouse.
I know there's a shock difference, but I don't think anybody knows the exact details. Probably not a big deal to ignore for now.


The air ride suspension valves replaced because they were all leaking. And suddenly it sounds  like car running over the groves on the edge of the pavement only I wasn't. Backed off the throttle and it sounded like car was running straight exhaust with severe vibration.

Felt sure I would find the drive shaft was the problem. The rear air bags had lost all the air. Crawling up under I discovered the linkage from the air valve had come out and allowed all the air out. 

The linkage was laying across the axle in good shape, just re-installed,went to Home Depot and bought a bolt to lock it in place--the old one had come out allowing the rod to fall out. Don't know if all air ride valves work this way but might not be a bad idea to check on occasion. I took the lock bolt back out ,reached my car garage  and used some locktite on it.
Till now all is well and problem is SOLVED.

------------
Solved car problems below :----

Car takes time to Crank and start?

http://howtobyme.blogspot.com/2011/12/car-takes-time-to-crank-and-start.html

Car jerks while going uphill and Check engine light is ON?


Car turns over, but only starts, if starter is jumped?


Service Engine Soon light stays on?


Gasoline around gas cap?


Car will not run after resetting inertia switch on Mercury Mystique?

VAN emits whitish bluish smoke and bad fuel smell from exhaust

http://schematicsdiagram.blogspot.com/2011/12/van-emits-whitish-bluish-smoke-and-bad.html


No comments:

Post a Comment